In order to serve you better we have moved our websites to the following domain names:


NFPS Main Site:

NFPS Website Hispana:

NFPS Foro Hispano:

E-Mail: [email protected]
See more
See less

MAG254 problem with WiFi

  • Filter
  • Time
  • Show
Clear All
new posts

  • MAG254 problem with WiFi

    I have just got a MAG254 device. I have bought a compatible USB pen (TENDA311M).
    When I try to connect to my Wifi router through the standard procedure (Network menu, Wireless...) I see my SSID in the list.
    I click on it and arrive on a page with ths SSID, the enrcyption parameters (WPA PSK, TKIP or AES etc.) and the passphrase box.
    I press the keyboard button and type the passphrase, then make the keybord disappear and press OK to save.
    So far so good but if I go on the portal page, the Wifi is indicated as Disabled.
    If I go on the Network parameters page, the Wifi is indicated as DOWN.
    I may reboot, this does not change anything,
    It looks as if the passphrase was wrong but I am sure to have entered it correctly.
    I also checked all encryption parameters.

    I have no idea as to what I can do.
    Thanks for any clue.

  • #2
    It may not be compatible with the MAG254. If you plug it into your W7 or W10 laptop does it start working correctly without looking for any external drivers?

    Some of these devices actually use the computer to do part of the decoding work and have to have special drivers installed to get the computer to do that work.

    I got stuck with a WIFI dongle that would not work on the MAG254 and had to order a correct one.


    • #3
      I have a TP-LINK N600 TL-WDN3200 that works great with the Mag254.


      • #4
        Thanks for your replies.
        I bought another dongle :
        which is also guaranteed to work witjh MAG254 but it does exactly the same as with the previous one :
        When pluged to the box, this detects all the WiFi nets around including mine. Then I go through the DHCP Auto procedure and nothing happens.
        In fact with both dongles there is a change when they are conencted : in the portal, the Wifi is indicated as DISABLED, whereas when no dongle is connected, it is said to be NOT CONNECTED.
        Thanks for any advice.


        • #5
          Have you checked how your password is coded (ASE , WPA PSK etc.) That happened with me . I thought it was WPA PSK 2 turned out to be ASE. Changed that and it worked.


          • WariWuf
            WariWuf commented
            Editing a comment
            Hello, sorry for the delay on the reply.
            I rest all the parameters as you indicated, 5horse, and it finally worked !
            Thanks to everyone.

        • #6
          Hey OP (original poster), so i recently decided to get a wifi adapter for my mag254 and encountered the same problem as you did. I think i may have found the solution.
          DO THE WIFI SETUP with ethernet cable connected.

          1) Connect your mag to your router via ethernet cable (rj45)
          2) Go to settings, wireless(wi-fi), Auto (DHCP),
          3) Choose your wifi SSID (the name), go next to the keys and encoding setup page, make sure your password and encoding are correct. (this is where i spotted the problem). Click okay.
          4) The encoding on this page defaulted to TKIP. So for me, when i first connected my wifi adapter to my mag and did the initial setup, when i did "NOT" have my ethernet cable connected, (if you remember you did this via another screen, the one where you saw wifi down), i had used encoding as AES.
          5) The problem was that the Magbox kept the default encoding as TKIP. so i had to use a ethernet cable to connect mag to router to change the default TKIP to AES.
          6) TL;DR - connect ethernet cable from mag to router (while having the wifi adapter connected), go through network wireless setup. make sure its not defaulting to TKIP encoding. and you should be set. I hope this was helpful...and i hope i was clear...not sure if my explanation makes sense.


          • #7
            Random102, your post is the closest I've read to giving complete instructions. I need further clarifications. I've followed your steps and I'm stuck. Per your steps,
            1. Choose Auto (DHCP)
            2. Screen shows "SSID (wifi "group"): I typed in my wifi name. Is this correct? If yes, I go to click "next" - do not hit "scan" button. If this right? Because hitting scan gives me a page with no wifi group
            3. So I went to "next" and the screen takes me to Encoding page where "Authentication" if the first field. Do I need to change the default on WPA2 PSK? I've assumed no because you didn't write it.
            4. Encoding, default is TKIP, I've changed to AES per recommendation
            5. Key or Passphrase, it is blank right now, so I've put in my wireless network security, is this right?
            6. Enter Ok
            7. I went to check network info but it's still showing Link status: Down

            Any assistance would be great!



            • #8
              My MAG 254 may be an older model, but I had to purchase an external antenna for fine.....


              • #9
                it is so simple if u have a wifi adaptor . Just press the right bottom button and it will work if ur adaptor is compatible with the device .


                • #10
                  I have read this entire log. I see that I am not the only one that had this issue. I have bought two wifi adapters that state work for MAG254, however I cant get it to work. Link: Down

                  Did anyone get a real fix???

                  Thanks a million


                  • #11
                    I always buy the aura hd wireless adapter and i never experienced any issues


                    • #12
                      Originally posted by Kodi View Post
                      I always buy the aura hd wireless adapter and i never experienced any issues
                      The Aura is what they sell on the infomir site to use with the mag254


                      • #13
                        I am not sure , I couldn't find any information on their website but they sell them on Amazon for about $7


                        • #14
                          I connected my mag254 to Internet shows up but when check network status shows no IP address no gatway address tried manual but could not any ideas why