In order to serve you better we have moved our websites to the following domain names:


NFPS Main Site:

NFPS Website Hispana:

NFPS Foro Hispano:

E-Mail: [email protected]
See more
See less

Mag 254 get a black screen

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mag 254 get a black screen

    Guys I need help I turn my Mag 254 on but the problem is after it says loading the screen goes black I tried doing IPTV reset but nothing I reset my modem nothing I am not getting the yellow bar or any ways to go to menu.

  • #2
    Is this the first time this has happen? How is your device connected to your TV? Have you tried waiting a bit after it shows loading?

    I know that with the new middleware it hangs on a black screen for longer then usual.


    • #3
      Does the setup button work after the screen goes blank?.....If so what type of TV are you using?


      • Madrid14031979
        Madrid14031979 commented
        Editing a comment
        I have a Roku TV but it never gave me any problems I don't even let me do the setup

    • #4
      I'm using a HDMI cable direct to the TV this started last week but today I was trying to watch TV I don't use my mag too often because I have another private provider


      • #5
        To access Bios you have to unplug the MAG 254

        On the remote press the bottom left button near the arrows (3 dots/3 lines), press and hold and aim this at your mag

        plug mag in, that should bring you to BIOS

        I'm doing this off the top of my head right now.


        • #6
          You are correct. The Mag is probably in Pal mode!!


          • #7
            yep ..happen to mag 254 was in pal mode. went to bois and change from pal and everything works now using remote.....Unplug your box and hold the button just above the + on the volume button and plug the box still holding this button. It should bring you to the
            Bois ...hope this helps
            Last edited by macieo2; 08-20-2016, 07:57 PM.


            • #8
              I had that problem already what work for me I deleted the mac address reset and then reenter the mac address again